Billing Incident
Incident Report for Commio Voice & Text Messaging
Resolved
Our vendor has confirmed that the service issue affecting billing has been resolved, and we've verified stability. We hope that our transparency shows our commitment to you and all of our partners. If you encounter any other issues, reach out to our support team via support@commio.com.
Posted Apr 20, 2022 - 14:25 EDT
Update
We continue to work towards remediation at this time with this vendor, and updates will be provided as soon as they are available. Thank you for your patience.
Posted Apr 20, 2022 - 12:22 EDT
Identified
We are currently experiencing an issue with Commio (thinQ/teli) partners who use Freshbooks billing services. We're hard at work on the issue with this billing partner, and more details will be provided as we research the issue and get a resolution timeline. Send a ticket to support@commio.com and monitor service status via: http://status.thinq.com
Posted Apr 20, 2022 - 09:17 EDT
This incident affected: Billing.