Inbound Voice Caller ID Issue
Incident Report for Commio Voice & Text Messaging
Resolved
Our vendor has resolved the intermittent service issue that was affecting Caller ID on inbound voice. We have been monitoring our network and have verified stability. We hope that our transparency shows our commitment to you and all of our partners. Thank you.
Posted May 26, 2020 - 16:04 EDT
Update
We are continuing to investigate this issue.
Posted May 26, 2020 - 16:02 EDT
Investigating
We are currently experiencing a service issue that is affecting Caller ID visibility for inbound voice services. We're hard at work on the issue. More details will be provided as we research the issue and understand a resolution timeline. Stay tuned. Send a ticket to support@thinq.com and monitor service status via: http://status.thinq.com
Posted May 26, 2020 - 15:06 EDT
This incident affected: Inbound Voice.